emacsのelpyで「Your ‘python-shell-interpreter’ doesn’t seem to support readline・・・」のエラー

emacsのelpyで下記のエラーが発生。

Warning (python): Your ‘python-shell-interpreter’ doesn’t seem to support readline, yet ‘python-shell-completion-native-enable’ was t and "python3" is not part of the ‘python-shell-completion-native-disabled-interpreters’ list. Native completions have been disabled locally.


python3が「python-shell-completion-native-disabled-interpreters」に含まれていないのが原因。

と、いうことで、「M-x elpy-config」で設定。
下の方にある「Option」→「Python」→「python-shell-completion-native-disabled-interpreters」を選択。


「INS」にenterで「python3」を追加。


関連記事

Comment

(編集・削除用)
管理者にだけ表示を許可

Trackback

URL
https://nosource.blog.fc2.com/tb.php/199-9144b069
この記事にトラックバック(FC2Blog User)

カテゴリ

Amazon

アクセスランキング

[ジャンルランキング]
コンピュータ
261位
アクセスランキングを見る>>

[サブジャンルランキング]
プログラミング
47位
アクセスランキングを見る>>

RSSリンクの表示

ブロとも申請フォーム

Copyright © nopgm